Mechanics

FORD ESCAPE ENGINE PROBLEM

2005 Ford Escape • 4 cylinder Automatic • 75,336 miles

I have a 2005 ford escape 4 cylinder engine 2.3 liter, it cranks but I can turn on the vehicle in any way not even with ether, it displays only dashes on the odometer and I don't know what this means, car wont start and the obd can does not link to the vehicle I have tried 3 more scanners an with all 4 scanners wont link too. The mileage registered is 75336 was placed on the work order.
Engine and transmission were pulled out just for a replacement of the front transmission seal and all has been placed in order I have check and double check all the electrical connections and rechecked all ground point and fuses, relays and all that is involved, there is a good spark in all 4 plugs and fuel pressure is in order but just wont start, engine was running perfectly and smoothly once the vehicle arrived and engine also was covered for dust or water entries. Any help would be great!
Avatar
Cruiserboy811
July 21, 2011.



THIS MAY HELP A LITTLE, IT'S ALL I HAVE TO OFFER

WIFE HAS A '03 3.0.I TRASHED IT'S TRANNY, $1400 TOTAL REBUILD

NOT WHAT I WAS GONNA TELL YA!

I COULD NOT LINK IN WITH MY SISTERS TAHOE. AS I WAS GIVING UP, I COULD NOT FIND MY LIGHTER, TO LIGHT MY CIGARETTE. HER LIGHTER IN THE TAHOE DID NOT WORK. BLOWN FUSE. SAME CIRCUIT AS TEST PORT

MAYBE. THE MORAL OF THIS STORY IS CHECK YOUR FUSES. MAY NOT BE THE FORD'S LIGHTER!

LET ME KNOW IF THIS HELPED!

THE MEDIC


Tiny
CJ MEDEVAC
Jul 21, 2011.