Mechanics

OIL LIGHT

2005 Chrysler PT Cruiser • 4 cylinder FWD Automatic • 74,000 miles

My 2005 P/T cruiser 74,000 miles just recently, when I start the engine, the oil light stays on, I restart the engine, oil light goes out. It doesn't need oil, I change oil regularly. Is it saying faulty oil pump? Or is it faulty sensor light?
Avatar
Cdooley
February 17, 2011.




Hello –

To better assist you, I know you said your model was an LX, but what I show is either just the PT Cruiser, or the GT, Limited or Touring……do you know which one of these. Also what is your engine size in liter?

Next – glad you checked your oil……PLEASE make sure you continue to do that. I would think it is more the switch than the pump. Not ruling it out…. Just seems more normal it is the switch.

Please go to Auto Zone (AZ) or O’Reilly’s (OR) and have them pull your codes to see if it threw one on the switch. They may hesitate if your check engine light didn’t come on but let them know it went on then off. I want to check to see if it threw any codes please make sure you tell us exactly what the code was, number and all. Example, if the code was E0568 O2 Sensor bad. Then make sure you give us all of that.

You might also check the wiring on the switch to make sure it has a good connection, not wet, corroded etc.

Let me know the above – most likely I will suggest a switch change.

Thank you very much for the donation

Please let us know if what the final fix was for your car so we can better assist others. Thanks!

Find a car repair manual for your car repair questions.

ImpalaSS
Feb 17, 2011.


AD