Mechanics

CAR WON'T START BUT CRANKS

2004 Kia Amanti • 120,000 miles

My Amanti wont start it cranks no start. I have check plugs change fuel pump, check fuel pump relay, check coils good spark very strong. It would try to start but it would die out. If I squirt a little starting fluid into throttle body it would start up and run-until it burns off. This only happen after I stop and put gas in my car it was running fine before. I stop turn car off put in gas try to start very hard engine running with now power.I started to drive home and it got better and run nice after a few minutes. I parked in the driveway and it would not start for three days now. Run code check it is giving me a code for the MAF sensor could this prevent the car from starting? I thought it was the CPS but no codes for that can you shed some light. Cpttrevor
Avatar
CptTrevor
October 5, 2012.




Would do Cpttrevor

Tiny
CptTrevor
Oct 25, 2012.
I would like to thank you for your help in attempting to fix this problem. Logically everything check out that should make a car start. Every time I sprayed starter fluid in throttle body car would run so this made me start thinking that my problem was some issue related to gas. So I decided to drain the tank and started all over again. I got the gas from Shell on 82 near sunshine blvd here in Florida in Lehigh Acres and I decided to drain tank and start over. I put in a 5 gal container of fresh gas and the car started and smoke like a mosquito machine for about and hour and then she start to run nice and clean. They sold me a bunch of bad gas. Just to prove it was bad we put it in another car that was working and the car won't start and when we removed it the car smoke like a smoke stack. The Kia is running fine now after all the expense of new cam sensor not needed, new tps not needed, new fuel pump not needed etc just a tank of bad gas put this car into limp mode and would not let it start. Cpttrevor

Tiny
CptTrevor
Oct 28, 2012.
Glad to hear it starts I would add a can of fuel injector cleaner like the chevron techroline and a fuel drier to a full tank of gas.

Saturntech9
Oct 29, 2012.
Would do thank you for the tip the check engine lite came on so I suspected 02 sensor and I was right I ran a code and it was the 02 sensor but I cleared it and it never came back. So I am watching that now but the car is running fine. Cpttrevor
AD

Tiny
CptTrevor
Oct 30, 2012.
Alright sounds good keep me posted.

Saturntech9
Oct 30, 2012.

AD