Mechanics

DODGE INTREPID RPM PROBLEM

2004 Dodge Intrepid • 138,000 miles

Please somebody help me. About 3 months ago I bought and had installed new tire rod end bushings. Both control arms on the front end. Also installed all new strut assembly's the whole way around the car. Did an oil change, and installed all new plugs. Now about 3 weeks ago I went to use my cruise control, I could see it turned on but it wouldn't engage. The next day I tryed to roll down my passenger window, it wouldn't go down. Both still aren't working, and now my radio will cut out & in. All of those are cosmetics to me my big issue is that recently I've noticed a loss in power while I'm driving. When I first turn my car on and start moving my rpm output is where it has always been in-between 800-1000. But once my engine warms up my rpms drop to 500-600, and I lose power. When this happens my car sounds like it wants to stall. When the the rpm's drop down theres a puffing/ hissing sound coming from the engine. Ive inspected every inch of the vacuum lines. Nothing! I'm lost, I don't really wanna go to a mechanic, just for them to give me a list off things that it could be. Money is tight I can't afford to keep buying part after part hoping that one of them fixes my issue. If someone could just point me in the right direction. Or make a couple of suggestions, as to what it might be. Because everyone I talk to seems as clueless as I am.
AD
Avatar
Guest
April 6, 2013.




Check to make sure the fuel pressure is within spec when this happens. Also, check the idle air control valve.



AD