Mechanics

CHEVROLET SILVERADO WIRING PROBLEM

2004 Chevrolet Silverado • 130,000 miles

I have a 2004 Chevrolet Silverado HD with a factory towing package. The wiring that comes from the truck to the back of the female receptacle is bad and some broken. I found a new pigtail but when I connect it I have a right turn signal that works properly but when I turn on the left turn signal both right and left blink. Also only one brake light comes on. I checked all the fuses in the truck and they are all good. Any ideas?
Avatar
Jayseno0
March 14, 2013.




Recheck your diagnosis, the wiring harness may have been damaged where you dont see it.

Dr. Hagerty
Mar 16, 2013.
Dr. Hagerty, (EXPERT) (haha!)Thanks for telling me to recheck my diagnosis. For your information, The reason I spent an hour on my back under the truck was to check the wiring harness at the places where I couldn't see it. Also I rechecked my diagnosis at least a dozen times. I didn't contact you to have you tell me to check it again. Lol!
Also I found and fixed the problem. The problem was in the 10 pin flasher module that is attached to the back of the fuse block under the dash. I replaced the flasher module and it fixed the problem. I hope that in posting this it will help others with a similar problem in the future.
I donated $10.00 to your cause and got an answer two days after I needed it, but I understand that life is busy and duties are taxing. Please keep the $10.00, seriously it is my gift to educate you so you can educate others. The work must go on!
P.S. Just a note in closing, pssst! You forgot to e-mail me your answer! Luckily I signed in and found it!

Tiny
Jayseno0
Mar 17, 2013.
.
AD

Dr. Hagerty
Mar 18, 2013.

AD