Mechanics

PROBLEMS WITH

2003 Saturn L200 • 4 cylinder 2WD Automatic • 70,265 miles

I have a 2003 Saturn L200 with 70,265 miles on it. I've had the fuel pump and serpentine belt tensioner replaced. The battery has been replaced with in the last 2 years.
Right now the fuel and temperature gauges work on and off. (Either they work or they don't move at all.) Also, the light for the odometer isn't working now either. Any guesses at what it could be?

Thanks Ashley
Avatar
Iris0004
March 11, 2011.




The odometer light is probably just a bad bulb. AS far as the temp and fuel gauge inop that is probably a body control module going bad. That's really common for those car's. So does anything else stop working like key less entry power door lock's inside light's etc?

Saturntech9
Mar 11, 2011.
Do you ever get a crank no start with the security light on solid or flashing?
AD

Saturntech9
Mar 11, 2011.
No problems with the key less entry or anything else, yet. And I haven't had any problems with the engine cranking and not starting. But my headlights and the inside lights (i.E. The radio, over head, and buttons for the windows) will sort of flicker while my radio is playing.

Tiny
Iris0004
Mar 11, 2011.
Those car's are known for flicker light's I would have the alternator battery etc checked. Also make sure the battery cable's are clean and tight. From the gauges those it sound's like the body control module is going bad that is some of popular thing's that happen when the body control module is going bad.I would have it checked out when the gauge's are inop.

Saturntech9
Mar 11, 2011.

AD