Mechanics

CAR WONT FIRE

2003 Oldsmobile Alero

Hey 2003 alero wont start there is power from the ecm all the cables ar good the starter has power I tried jumping the solinoid and it turned over normally but wouldnt fire but when you use the key to try and. Start it absolutly nothing happens the starter doesnt even. Click everything has power and the battery is. New also I should mention. The fuel pump was replaced 6 months ago so basically starter is fine ecm has power new battery turns over when starter is jumped but wont fire nothing happens when turn the key to start also security system is. Fine no flashing just light comes on and goes. Off right away any help will be greatful
AD
Avatar
Hubskies
July 13, 2012.




So were sure the battery cables are clean and tight?Also is the security light on solid or flashing. Any codes?Also do you have a multimeter to do some testing?
AD

Saturntech9
Jul 13, 2012.
100 % all the cables on the battery and starter are tight and the sucurity light only comes on briefly when acc is turned on then goed out right away like it should I have a multimeter and tge voltage at the starter alternator ect is all good like i. Said when I jump the starter it turns over normally just wont fire!

Tiny
Hubskies
Jul 13, 2012.
Also when trying to start with key there is nothing no clicking just nothing

Tiny
Hubskies
Jul 13, 2012.
Do you have any codes?Have you checked for codes?

Saturntech9
Jul 13, 2012.
Have not checked for codes I dont have a code reader do you have any ideas as to what the problem could be?

Tiny
Hubskies
Jul 13, 2012.
Checking for codes could speed the diagnoses process code readers are cheap these days.I would start by seeing why the starter is inop may lead to the other problems. What size engine do you have?

Saturntech9
Jul 13, 2012.

AD