Mechanics

NO ACCELERATION

2003 Nissan Altima • 4 cylinder FWD Automatic • 112,000 miles

Hello. I have some irregular starting problems. At first my car would start but would not move. I left it sitting and a few hours later, it started with no problem, and I was able to drive it. A couple of days later, it just stop starting. It would just click. The battery and alternator are good so I was thinking the starter. But what would restrict my car from accelerating? I had a mechanic tell me it was my alternator but it doesn't sound like the problem. I had another mechanic tell me it could be my transmission. I fear its the fuel pump! What do you think?
Avatar
Dbadajos89
November 28, 2010.



The non starting with only clicking noise present is most likely to be due to a failing starter since the battery and alternator have been tested to be good.

Note : Some maintenance free batteries are known to fail intermitently and when problem occurs, it would be recommended to test the battery there and then to confirm it is not the cause.

As to vehicle not accelerating, do you mean the engine rpm does not go up when accelerating or engine revs without vehicle moving?
Does it occur in all gear positions other than P or N?
Have you tried to retrieve for trouble codes?
Is the Check Engine Lamp indicating?

A fuel pump problem would result in difficult starting( engine cranking but not firing up) and engine not responding well to accelerator even when in P or N position.

KHLow2008
Nov 28, 2010.