Mechanics

CHECK ENGINE LIGHT CAME BACK ON... MECHANIC SAID TO REPLACE UPPER/LOWER MANIFOLD GASKETS?

2002 Mercury Sable • 72 miles

Over past 2 months, have replaced fuel filter, all plugs, coil pack. Overall performance is ok; the accel seems fine, but at idle, engine acts like it's missing. Mechanic wants $220 to perform work. He sprayed brake cleaner looking for vacuum leak(s). Is this the next best thing to do? Do you think the check engine light will stay off? Thanks.
Avatar
Pogo824
December 31, 2011.




What are the exact code numbers you have?

Saturntech9
Dec 31, 2011.
I (mechanic) did not write them down, so I'll go by Auto Zone.

Tiny
Pogo824
Jan 1, 2012.
Alright let me know have a safe and happy new year.

Saturntech9
Jan 1, 2012.
Happy New Year!
Here are the codes from Auto zone.
P0171
definition: fuel trim bank one condition
explanation: the power train control module uses the oxygen sensor to calculate the air/fuel ratio of the engine. The computer has recognized a rich or lean condition on one engine bank only.
P0174
definition: fuel trim bank two condition
explanation: the ECM has detected a rich or lean air/fuel ratio condition on engine bank two.

What do you think?
Thanks, paul

Tiny
Pogo824
Jan 2, 2012.
Yes a vacuum leak will cause those codes I would just make sure the intake is leaking vacuum before replacing the gaskets. If it is leaking I would straight edge the manifolds to make sure there not warped while replacing the gaskets.

Saturntech9
Jan 2, 2012.
Ok, thanks. Another question - given I've already removed the plenum to change the rear plugs, is putting on new gaskets a big job? Also, is there any harm in driving the vehicle, like 2 weeks until we have the $$?
AD

Tiny
Pogo824
Jan 2, 2012.
Its not a bad job to do as far as waiting a couple of weeks I dont see the harm in that.

Saturntech9
Jan 3, 2012.
We now have moved to an urgent mode. The engine is cutting off when you come to a stop. It will hiccup and then cut off; does re-start, so dropped off vehicle at the mechanic's garage last night. UGH!
Do you have any comments or possible solution(s)?
Thanks, paul

Tiny
Pogo824
Jan 4, 2012.
Need more details did we get any new codes?Also why doesnt it start did we loose spark fuel presure injector pluse?Let me know.

Saturntech9
Jan 4, 2012.
SOLVED by the mechanic! Under the plenum he found a hole (more like a slot for a quarter) in the emissions/vacuum hose and pipe - replaced it. Think we are now good to go.
Thanks for your assist, Paul

Tiny
Pogo824
Jan 5, 2012.

AD