Mechanics

MAZDA 626 ENGINE PROBLEM

2002 Mazda 626 • 104,000 miles

Hi. Just got a used mazda 626. With 104k miles…everytime I stop it has a rough idle and the engine shakes like it wants to turn off. The moment I start to drive it goes smooth …there is no check engine light on. So I cant think of why is it happening. Please let me know, thank you.
Avatar
Azejnati
November 19, 2012.



Idling speed is too low.


KHLow2008
Nov 21, 2012.
Can you help me to get the idle speed a little higher? And how high? Thank; s please let me know.


Tiny
Azejnati
Nov 21, 2012.
Which engine do you have?
Try cleaning the throttle body and IAC first.


KHLow2008
Nov 22, 2012.
Hi. It is the 626 2.0 liter. I did clean the throttle body. It was actually clean. Now I dont know how to raise the idle speed….[; Ease let me know thank you.


Tiny
Azejnati
Nov 23, 2012.
Refer to diagram.


KHLow2008
Nov 23, 2012.
Hi. And thank you for your advice…. The idle is the right timing 650rpm…. It still shakes when Im stopped …and I cleaned the IAC valve. Could it be the timing belt? The valves? Because when I drive it is perfect…. Please let me know….


Tiny
Azejnati
Nov 23, 2012.
650 might be too low. Try increasng to 750 and did you use a jumper between the TEN terminal at DLC-1 and ground?

Check the engine mounts, they could be bad.


KHLow2008
Nov 24, 2012.
Hello. And thank you. The screw for the idle is tightent in max, doesn't go more. So I really cant change the idle at all. And what is this jumper you are saying with terminals. I have never heard of it at DLC-1 please let me know. And can you tell if the engine mount are bad just by looking at them?


Tiny
Azejnati
Nov 24, 2012.
Tightening would decrease the idling speed. You need to turn it outwards.

Refer to link below for information on the DLC-1

http://www.2carpros.com/articles/diagnostic-trouble-codes-for-1995-and-earlier-mazda-cars-obd1



KHLow2008
Nov 24, 2012.