Mechanics

FORD WINDSTAR MECHANIC PROBLEM

2002 Ford Windstar • 190,000 miles

Van started idling high last week. Had it scanned by mechanic and got 1504, and 1506. Was told to replace the IAC, and TPS and did so. Problem continued, and thought maybe the new IAC was defective so Iexchanged it. Still have the same problem. Had all the vacuum lines tested and they are all good. What else could it be. Also took the TB off and cleaned it.
Avatar
Mbob2772
November 9, 2012.




There is a malfunction with the iac control. Codes never identify bad parts, just failed systems. It needs to be scanned by a real tech, not a parts salesman to determine the failure.

Roy

This was scanned by a mechanic, not a parts store.

Tiny
Mbob2772
Nov 9, 2012.
Good, most people have a code pulled from a parts store and they sell them parts.

Sorry.

What was the techs diag? He should be able to track this down with a scan tool by operating the iac with the scan tool.

Roy

He told me the IAC was the problem. But that did not fix it.

Tiny
Mbob2772
Nov 9, 2012.
It also does it when I turn the steering wheel.

Tiny
Mbob2772
Nov 9, 2012.
Ok, he needs to continue helping you as his diag was incorrect making you not liable for that repair.

Roy

I just tried unplugging the IAC. When it is unplugged it runs normal.
AD

Tiny
Mbob2772
Nov 9, 2012.
It should idle at 500 rpm when unplugged. Make sure the base idle is set correctly

Roy

It is at around 500 unplugged and 1500 plugged in

Tiny
Mbob2772
Nov 9, 2012.
You may have a bad iac.

Roy


AD