Mechanics

FUEL PUMP PROBLEMS

2002 Chevrolet Silverado • 170,000 miles

I replaced the fuel pump on a 2002 chevy 1500 4.3 p/u, ran great parked it the next morning would not start. Put new fuel filter cleaned trottle body, next morning started up. Drove that day off & on drove 20 miles to put tires on it then it wouldn't start at the tire shop. Towed it home. No fuel pressure at all, power is getting to the wires going into the blk sensor on top of the pumper, but no power from the other wires going to the other connector on top of the pump. Is there a fuse to ck to these wires going to the pump. Or is there something else I need to do? Please help, thank you Vicki
Avatar
Vickiayala
June 16, 2012.




So you have power going to the fuel pressure sensor on top of the fuel pump module?But no power the fuel pump connector itself?

Saturntech9
Jun 16, 2012.
There are two electric plug on top of the 2002 chevy fuel pump. One is a black sensor that pops off and the other is cream color. The wires going to the blk one, I put a test light and there is power to the gray wire. But the other wire plug in is blue and none of the four wires have power coming from them. And I tested them with the truck key turned ON. I pulled the fuel line from the pump to the fuel filter turned on the key no fuel. No pressure coming out the port by the trottle body. But my questions is; doesn't there have to be power coming into both those plug wires to the pump. Is there a fuse, besides the fuel pump relay? The relay is working with the test light.
AD

Tiny
Vickiayala
Jun 16, 2012.
The one you have power to is the fuel pressure sensor which is normal. Your only going to have power to the other connector which goes the fuel pump and fuel sending unit for the first couple of seconds with the key in the run position. Unless the engine is running. You will have to have someone crank the engine while checking for power at that connector. What model silverado do you have 1500 etc?Also what size engine do you have?

Saturntech9
Jun 16, 2012.
It is a 1500 4.3L short bed automatic TWD

Tiny
Vickiayala
Jun 16, 2012.
For the 4.3 I need the 8th digit of the vin they have two different 4.3 for that truck.

Saturntech9
Jun 16, 2012.
Alright its the same for both engines black is ground and the gray wire is power while cranking the engine.

Saturntech9
Jun 16, 2012.

AD