Mechanics

COULD NOT FIND ANY BROKEN LINK?

2002 Buick Lesabre • 160,000 miles

When I took car to Sears to have brakes replaced they told me a link broken on left rear & shock leaking- take to dealer for repairs on that.

02 Buick LeSabre. Got my rear shocks replaced due to leak in left rear shock. They could not find any broken link. Drove it home and it squeaked alot and some other noise mostly on the left side. Took it back again and they determined that the left shock was defective so replaced that. Noise was still there on left side so I went back the third time and this time they said it was the load leveler, that they sometimes get dried out so they lubed it. Noise still there!

I can hear it when driving and when I bounce the rear end and so has the service dept. Mgr. Any ideas? I feel like I'm getting jerked around and I'm getting really frustrated with having to take it back time after time. The mechanic that worked on it left a rubber cap in trunk so I took a pic of it and called service dept to ask what it was for. Told that it was for the shock but just cosmetic? Could that be part of the problem? I'm not sure what it is exactly for but I do have the pic I took. Do you have any insight as to what is going on?

HELP please! Thanks. Judi
Avatar
Izblu
September 30, 2012.




First, I would take it back, leave it there till they get it right. Do not accept the car till it is correct.

It could be a suspension part other than the strut. Hard to diag here without seeing and feeling it.

Roy

ASEMaster6371
Sep 30, 2012.


AD