Mechanics

P1388 & P1684 ODB2 CODES

2001 Dodge Intrepid • 200,000 miles

Ok, I have been having some problems with this Intrepid again. I have a feeling it has something to do with the cam and crank sensors. I have replaced them both 3 times and it seams that the problem goes away for a short time then comes back. The codes are saying that its an asd relay fault, which is grounded by the pcm right? Well if I manually ground pin 85 of the asd relay, the car will start, run, and drive fine. I'm about at my whits end here. The car has 222000 miles on it and so far has been ok until you guys helped me a couple months ago figuring out that my cam and crank sensors were bad. About a week ago I ran the codes and it said something about irregular signal from cam and crank sensors. I thought about replacing them again but I'm thinking that I may have a short somewhere in the bus loop. Am I going to damage anything by grounding the asd relay while driving? This is my wife'scar and I don't want her to have to get under the hood every time she goes somewhere.
Avatar
Craig jaster
April 15, 2012.




Do not bypass the computer gorund as you will cause other issues.
Is this the 3.5 motor? If it is, have you changed the timing belt?

Otherwise, you may have a wiring issue or a bad pcm.

Check the harness in the back of the motor as I have seen many harness issues with broken wires at that point.

Roy
AD

ASEMaster6371
Apr 15, 2012.
I believe its 2.7 litre. It's the SE model if that tells you anything. I will check out the wiring tomorrow in the day light. See where that goes. Thanks for the ideas.

Tiny
Craig jaster
Apr 15, 2012.
Good luck

Roy

ASEMaster6371
Apr 15, 2012.
After I replied last, I went out and the car fired right up and drove fine still not having any problem but I know its still there just hiding.

Tiny
Craig jaster
Apr 17, 2012.

AD