Mechanics

CHRYSLER 300 COOLANT PROBLEM

2001 Chrysler 300 • 207,000 miles

I just recently traded for my 2001 chrysler 300m and noticed there was a vacuum leak (caused the idle to sway a little) and a small rad leak. A week went by and a rad hose popped off going to the heater core, lost most of my coolant. I took it into a shop hooked up the hose and topped up my coolant and tried to figure out this vacuum leak. Turns out its the EGR valves and the grommets are torn. Who ever preveously owned the car had the valves slightly off. My mechanic ordered grommets and put the two valves into place (a check engine light came on right away stating a coolant temp). Meanwhile we have had overheating issues and seems to be going throu coolant faster then usual but no leaks! When it was over heating we checked the coolant and there was a huge steam build up, so we cracked the bleeder open and filled the coolant as much as possible to push the steam out. Now the temperature reads under half way. Last night we went for a 20 min drive and we cud smell coolant right away a oil pressure light came on (was not flashing and oil is full) I checked the hose where the thermostat is and it was not as hot as the other hoses. Today I started it up and the idle was really low and rough I had to give it some gas to keep it from dying. (The oil pressure light was no longer on) I took the EGR valves off again started it up and it red lined right away so I put them slightly back on like it originally was. My check engine light is still on and im lost I know the thermostat needs to be replaced but I need good advice on my on going daily problems. Can you help?


Avatar
Guest
December 1, 2012.



Check out the related content below while we wait for the question to be answered by a professional mechanic.