Mechanics

ROVER RANGE ROVER BATTERY PROBLEM

2000 Rover Range Rover • 143,000 miles

Hello PLEASE HELP

I was having problems with my battery going dead overnight and needing a jump to start. I have replace the battery although now when I get in to start my truck I dont hear a click I get nothing and all power goes away. I dont have original paper work as the truck was giving to me and I have tried the 1515 to over ride immobilizer although nothing happens. I do see that the alarm is active according to the light on dash yet it blinks once followed by two fast blinks. Can someone help me in what is the problem with my vehicle as to why it wont start even with new battery with out a jump.

thank you
Avatar
Martellowens
February 4, 2013.



THIS MAY OR MAY NOT AID YOU

BUT I RECKON IT'S BETTER'N SEE-UN YOUR QUESTION SITTING IDLE!

GOT 2 THINGS FOR YOU

THIS BEING WHAT I SEE......MOST OF THE TIME!

http://www.2carpros.com/questions/1996-chevrolet-tahoe-wont-start-sounds-dead-battery-jumpbox-get-same-reults

THE OTHER IS CONCERNING PARASITIC DRAINS

http://www.2carpros.com/questions/1989-ford-tempo-98-tempo-bran-new-battery-shut-car-off-didn-t-days-now

LET ME KNOW IF THIS HELPS

SHOULD YOU NARROW IT DOWN TO A CERTAIN CIRCUIT---LEMME KNOW WHAT ALLS ON THAT CIRCUIT (stupid example__LIKE WIPERS AND AND DOME LIGHT)---ANY MORE NOMENCLATURE OF YOUR RIG TO INCLUDE IT'S ENGINE SIZE

I MAY BE ABLE TO GET YOU SPECIFIC DIAGRAMS SHOWING WHAT IS IN THE CIRCUIT AND LOCATIONS OF THE COMPONENTS---(DON'T ASK FOR THE ENTIRE WIRING DIAGRAM FOR THIS VEHICLE--THERE MAY BE HUNDREDS OF DIAGRAMS!)

LET ME KNOW HOW IT'S-A-GOIN'!

THE MEDIC


Tiny
CJ MEDEVAC
Feb 4, 2013.