Mechanics

MITSUBISHI ECLIPSE CLUTCH PROBLEM

2000 Mitsubishi Eclipse • 150,000 miles

Just put a new clutch pack in and now the transmission is leaking gear oil through the inspection plate what is the cause of this? I cant figure it out is there a seal on the input shaft? I put the new clutch pack about a week ago please help
Avatar
Gregge
November 11, 2012.




Can we have more info? Stick or automatic? Engine?

Roy

ASEMaster6371
Nov 11, 2012.
Standard 5 speed in a 2000 mitsubishi eclipse gt

Tiny
Gregge
Nov 11, 2012.
A stick

Tiny
Gregge
Nov 11, 2012.
Ok, now we have something to work with.

Did you remove the nose cover that the throwout bearing rides on? It has a seal for that.

Was anything broken for this repair?

Are you sure it is not engine oil from the rear main.

Roy

ASEMaster6371
Nov 11, 2012.
Did you replace the transmission shaft seal? So you put in a clutch disc, pressure plate, and throw out bearing am I right?
AD

Cadieman
Nov 11, 2012.
No I didint remove the nose cover I just removed the throwout bearing and the arm it sits in I puled the whole trans out including the bellhousing I didnt see anything broken its diffinately gear oil I smelled it

Tiny
Gregge
Nov 11, 2012.
Yes I put in clutch pressure plate and thowout bearing and no I didnt replace the shaft seal

Tiny
Gregge
Nov 11, 2012.
Is that my answer the shaft seal thats what im leaning on I should have changed it also how hard is it to change?

Tiny
Gregge
Nov 11, 2012.
I do believe I answered my own question but where can I buy a new shaft seal autozone doesnt carry them

Tiny
Gregge
Nov 11, 2012.
Check the dealer its not expensive.

Cadieman
Nov 12, 2012.

AD