Mechanics

ECT SENSOR LOCATION

2000 Mitsubishi Eclipse • 160,000 miles

I am bout to find the ect sensor do you know where it is located on my 4G64 engine or 2.4L. I have looked all over the internet and no one will say.
Avatar
Eclipse210
August 10, 2012.



By the thermostat housing.

Why are you chnaging it?

Roy

ASEMaster6371
Aug 10, 2012.
I had asked what could cause my car to idle low and they said to check my ect sensor but I will check it if it is still good if not I have a new one. Don't know if you could see my other questioned I asked it is titled idles low.

Tiny
Eclipse210
Aug 10, 2012.
Ect will not be your failure.

Could be dirty throttle body. Vacuum leak or bad throttle body.

Roy

ASEMaster6371
Aug 10, 2012.
I have cleaned my throttle body and looked for a vacumn leak and found none. I have replaced the egr valve and the solinoid and spark plugs and tps sensor and the iac valve and still having idle low issues to where it wants to die. But only does it when it is warmed up. I had asked this same question earlier and the guy told me to check the coolant temp sensor which I just replaced since it was only 17 dollars to replace just drove it around the block and does seem to be better but just seeing why you are saying it is not my failure, plus how could I tell if my throttle body is bad

Tiny
Eclipse210
Aug 11, 2012.
It would have to be smoke tested to see if it is leaking from the throttle body bushings.

Roy

ASEMaster6371
Aug 11, 2012.
Did you clean the ISC (IAC)?

KHLow2008
Aug 11, 2012.
Yes I did

Tiny
Eclipse210
Aug 11, 2012.
What is the idling speed at operating temperature?

KHLow2008
Aug 11, 2012.
It should be like 4 or 500 but now it's like 300 and below from all the stuff I have done it is getting better but just doesn't stay at normal idle speed

Tiny
Eclipse210
Aug 11, 2012.
That is an indication of a fault with the ISC. I would have that rechecked.

KHLow2008
Aug 11, 2012.
Page 1 of 3