Mechanics

STUTTER/MISS/HESITATION IN V6 2.5 L

2000 Mercury Mystique • 149,000 miles

I just purchased a 2000 Mercury Mystique. It has a rough miss/ hesitation that first was only right around 2000 rpms -40 mph-60mph. It shows no codes and has no lights on. Also when it starts to stutter if you lay into it, it clears right out. We have cleaned the mass air flow sensor, replaced the coil pack, and replaced the crank sensor. We didn't end up replacing the spark plugs and wires because they looked great. After cleaning the MAF sensor it temporarily ran a little better. The hesitation was less rough, but with in a day, it was right back. My mom had read online that we needed to unhook the battery, clean the MAF sensor, put it back together and then drive the car for 25 miles. Well. Needless to say now that's done, I think it's worse. The car will stutter/hesitate anywhere from 1500 rmps to 2700 rpms at every speed! I've been putting fuel injector cleaner in every time I put gas in, I'm not sure if thats made a difference at all. PLEASE HELP!
Avatar
Brennaw
February 24, 2012.




Try unplugging the MAF and test drive it, Ford recommends replacing the MAF, not cleaning it, and it does not usually work on Ford. My guess with these symtoms, and Ford history, MAF is the most likley cause.
AD

Merlin2021
Feb 24, 2012.
Unplugging it made it slightly worse. Won't the MAF set off a code if it's bad? Or a light of some kind?

Tiny
Brennaw
Feb 28, 2012.
Sometimes yes sometimes no. Ever changed your02 sensors? With your mileage, its time.

Merlin2021
Feb 28, 2012.

AD