Mechanics

MY CAR DIES

2000 Mercedes Benz 190d • V8 2WD Automatic • 195,000 miles

I have a 2000 sl500 that shuts off when the engine gets to hot. At first it would only do it after I would drive it for a while and then turn it off, if I would try to turn it on all it would is just crank over but will not start. Know its doing it even as I am driving, if the temperature just goes a little over half way (80c) it turns off and I have to open the hood and let it cool down for about 15 min and then it will start. Does it have some type of Thermal shut off that mayby has gone bad?'.
Avatar
Israelmendoza
July 21, 2011.



http://www.2carpros.com/articles/car-cranks-but-wont-start

Next time it refuses to start don't wait for it to make up its mind-do below immediately to determine if its fuel or spark problem

Get a helper disconnect a sparkplug wire or 2 and ground it to the engine atleast 3/16 away from ground-have helper crank engine over-do you have a snapping blue spark? If so-you have a fuel related problem, Do you hear the fuel pump come On when you turn key on? If not check fuel pump fuse and fuel pump relay if okay-check the fuel pressure to rule out the fuel filter/fuel pump/pressure regulator and listen to the injector/s are they pulsing or hook up a noid light. No snapping blue spark continue to troubleshoot the ignition system-power input to the coil/coil packs,coil's resistances,cap and rotor,distributor pick-up coil, ignition control module, cam and crank sensors and computer Note: If it doesn't apply disregard it and keep testing

Rasmataz
Jul 21, 2011.