Mechanics

4.3

2000 GMC Sonoma • 6 cylinder 2WD Automatic • 75,000 miles

Enter your question.I DON'T HAVE ANY HEAT, I replaced the therm. And all. Switches seem to be working. There dosen't seem to be any water circulating thru heater core. The engin isn't overheating. Could this still be the water pump.
Avatar
Skipel23
November 19, 2010.




Does it run at operating temp?
Run engine and check heater hoses by the fire wall if both hot and no hot air inside
problem is in the heater box and blend door or blend door actuator


BMRFIXIT
Nov 19, 2010.
Also check if it has a heater control valve


Tiny
Rasmataz
Nov 19, 2010.
The engin runs at operating temp. The inlet hose gets warm, but not hot and the exit hose stays cool. It is like there isn't enought pressure in the line. Does the blend box stop the flow of the water.


Tiny
Skipel23
Nov 20, 2010.
They do not use a valve in this system and blend system was used
as they direct the air thro and over the heater core and or the AC system and fresh air

heater core need to be isolated and flushed


BMRFIXIT
Nov 20, 2010.
I did that and water runs thru it freely.


Tiny
Skipel23
Nov 20, 2010.
If water running thru freely and no heat on the inside, engine reaching operating temp,
check blend door operation and I would suspect the actuator on the door


BMRFIXIT
Nov 20, 2010.
When I say water is rinning freely, It is with the hoses disconnected. How do I get to the actuator.
AD


Tiny
Skipel23
Nov 20, 2010.
Under the dash on the heater box
i will try to find a picture for you


BMRFIXIT
Nov 20, 2010.
Thanks


Tiny
Skipel23
Nov 20, 2010.
This a picture of the part and what it look like
let me know


BMRFIXIT
Nov 20, 2010.

AD