Mechanics

CHEVROLET ASTRO TRANSMISSION PROBLEM

2000 Chevrolet Astro • 15,700 miles

A few years back my sun shell broke and the sun gear had been stripped. Made it the 1/2 mile home and then rebuilt the tranny. It was my first one and every thing has been going good with it for the last 25,000 miles. When I rebuilt it I put in a shift kit that the transmission part supply shop told me to do to get rid of the shudder in the torque converter. It was a mr shift kit. My question is now the transmission seems it won't release or disengage until I'm completely stopped. Happens motor warm, cold, no difference. And only happens 60 percent of the time. When every thing is right or as it should be, I feel the tranny going down from 3rd to 2nd to 1st approiatly and no push but when not right the idle is high and late down shift from 3rd to 2nd and then down to 1st after about 2 mph or so to stop then a release and idle down. If I put it in neutral before slowing the idle stays some what high like 1,100 rpm till close to stopping then idles down to the correct idle app. 750 rpms. So I don't know if its the tranny or an idle vacuum issue. Do you think it could be the lockup solenoid? Going to do a transmission fluid and filter change and thought you might have a suggestion on what to check while I am in there. Or What to check with the idle circuit.
thanks for the help in advance.
AD
Avatar
Yzmatt31
December 4, 2012.



Check out the related content below while we wait for the question to be answered by a professional mechanic.


AD