Mechanics

ELECTRICAL/FUSE PROBLEMS

1999 Subaru Forester • 150,000 miles

My dashboard recently stopped working-no speedo, odo, tach, turn signals, all the lights except for the 'open door' light, hazard indication and gas gauge. Also power windows are out. Headlights still work, as do hazards, brakelights, inside lights, wipers. The car started a few times but recently stopped starting after the hazards were on for ~40 min. Any ideas? So first off, most of this was controlled by the fuse corresponding the 'meter' under the hood. If you check the manual, you can find out which fuse that is. My problem was after I replaced it, it pretty much blew again immediately. I took it to a shop and the guys found that some of the wiring from the speedo had worn off and was flapping around under the hood, and would short the circuit, causing the hood to blow. I got the wiring fixed for 4 hours of labor ($196) and haven't had a problem with it since. I have the same issue but I checked the meter fuse and it is good but yet I have no spedo, no odo, temp gauge and my windows do not work it started for a while but now when I try to start it it just turns over but will not start and if I spray starting fluid into the air intake system it will start but shuts off after the fluid runs out
Avatar
Larrypurcell2003
November 10, 2011.



Check the fuel pressure I its within specs and also look for ignition spark-also have the ignition switch

Rasmataz
Nov 10, 2011.
How would that solve the issue with the dash board?

Tiny
Larrypurcell2003
Nov 10, 2011.
You can start checking all the fuses, circuit breaker-lacking electrical experience-best just bring it in to the electrical pros-you got some serious problem here

Rasmataz
Nov 10, 2011.