Mechanics

WHAT IS CAUSING MY WIPER MOTORS TO GO BAD?

1999 Jeep Wrangler • 130,000 miles

I have a 99 Jeep Wrangler. I replaced a bad wiper motor recently. The new one worked when I put it in, and then when I used it the first time driving in the rain it stopped after about ten minutes. The fuse is good. The sprayer still works. Any idea what might be causing the motors to go bad?
Avatar
Walterwhitmyer
July 23, 2012.



Are they new or used motors?

The area they are located is subject to all kinds of weather. Make sure the drain is open for the water to drain from the area.

Roy

ASEMaster6371
Jul 23, 2012.
They are "new" ie, remanufactured motors. The boot that goes over the motor was dry rotted and unserviceable, so I covered the whole thing in electrical tape. I'll check to see if the area is draining. Thanks.

Tiny
Walterwhitmyer
Jul 23, 2012.
I wonder with all that tape that the motor is overheating from no air at all.

Roy

ASEMaster6371
Jul 23, 2012.
Don't know! The boot was very tight, and the installation guide said it must be in place.

Tiny
Walterwhitmyer
Jul 23, 2012.
Hi guys. There is a real common problem with the ground straps. Next time it "fails", either push on the motor to see if it starts running or better yet, measure the voltage on the case with a test light or voltmeter. If there's any voltage there look at the brass strap riveted to the mounting plate and attached under one of the bolt heads. It burns away under the bolt head. The permanent fix is to add a ground wire from the mounting plate to the body sheet metal.

Caradiodoc
Jul 29, 2012.