Mechanics

WHY IS THE ENGEN SHUTERING AND IM LOOSING BRAKE POWER AT RANDOM?

1999 Isuzu Rodeo • 150,000 miles

I have a '99 rodeo ls rwd on 4x2 chasis has trooper style v6 (uses trooper belt and random 4x4 parts)its been a pain. Had braking issues system has been gone through parts replaced include master cylinder part of the abs system, pads. Its been working fine for months but now the engen is shutering and brakes are failing with it.
AD
Avatar
Dan_o_man
September 8, 2012.



When engine stalls, the brakes would not work with power assist after 2 strokes.

Seems the idling speed is too low causing the problem.

Try cleaning the throttle body and IAC.

Is the Malfunctioning Indicator Light showing?

KHLow2008
Sep 8, 2012.
Thanks and yes "check engen" light is on. I have noticed when braking the rpms do drop "hard".

Tiny
Dan_o_man
Sep 8, 2012.
Get the trouble codes retrieved and let us know the EXACT code.

Most parts stores provides free scanning services.

KHLow2008
Sep 8, 2012.
Ok I got the codes ran. P0101, p0172, p0175, p0401, p0420, p0430. Some of these codes are for parts I have relpaced, mass air flow sencer, o2 sencers, and both cats.
Its the 3.2 v6
AD

Tiny
Dan_o_man
Sep 14, 2012.
Were the codes cleared after replacement of parts?

P0101 – Mass or Volume Air Flow Circuit Low Input
P0172 – System too Rich (Bank 1)
P0175 – System too Rich (Bank 2)
P0401 – Exhaust Gas Recirculation Flow Insufficient Detected
P0420 – Catalyst System Efficiency Below Threshold (Bank 1)
P0430 – Catalyst System Efficiency Below Threshold (Bank 2)

The rich running condition leads to P0172 and P0175. These codes do not indicate any particular component.

Rich running conditions for extended periods leads to failed catalytic converters due to excessive fuel getting to them causing overheating.

What you need to address now would be the EGR (P0401) and MAF(P0101) first.

KHLow2008
Sep 15, 2012.
After replaceing the cats and o2s it stayed clear for 800 miles. After repalceing the mas air flow sencer it did not. I reset by pulling battery for a few minutes and replaced, code stayed off till it ran its test then came back on. How do I check the egr flow?
It has been dificult to find any thing in haynes or other books due to the fact it dose not have the standard engen setup. (Mine uses parts from the trooper like the belt and uses 4x4 parts in the motor like the fule presure regulater valve witch I replaced).

Tiny
Dan_o_man
Sep 15, 2012.
Recheck the MAF. If it is a used unit, try another. Ensure its wiring socket/connector is clean and secure.

Let us start with this first. It can cause the EGR code as well.

KHLow2008
Sep 15, 2012.

AD