Mechanics

GMC YUKON SENSOR PROBLEM

1999 GMC Yukon • 198,000 miles

Ac problems will not engage clutch from switch want jump from pressure switch but can engage from battery to ac compressure but lines freeze up changed pressure switch still no engaging of compressure blower works ac light on dash lights both fuses and relays good all have power could it be a low pressure switch changed high pressure switch please help could it be a orfices filter clogged
Avatar
Jameshiers
November 14, 2012.



First of all, do you have the correct amount of refrigerant in the system? If so it could be a pressure switch or a blockage. You need to have gauges hooked up to it to monitor pressures in high and low sides to properly evaluate the system.

Homer1967
Nov 14, 2012.
I did jump ac compressor from battery and added fron but it still didn, t solve ac coming on normal what would correct pressure be on high and low side. Changed pressure switch twice now on evaporator bottle on rt side of firewall and worked for awhile but now can't jump it from there anymore to make compressor come on. But can jump from battery to compressor to make engage clutch but freezes the lines thanks for answering my question. And the help. Also have p0160 and 0140 codes have changed catyalic converters complete y pipe system dual exhaust and all four sensors and cleared codes but after running for a short distance the codes pop back on could it be bad new sensors put magnflow after market pipes and converters. And aftermarket sensors at 630.00 for pipe and converters and 60.00 a piece for sensors could that be the problems for the codes coming back on please help have changed crank sensor iginition module' plugs, cam sensor, coil, wires, cap, rotor button catyalitc convertor due to rt side came loose and clogged seems like rt side sensors are where codes are coming from. Please help.

Tiny
Jameshiers
Nov 14, 2012.