Mechanics

TRYING TO PROGRAM A NEW ECM

1999 Ford Expedition • 190,142 miles

Vehicle was missing on #1 & #6 cylinders. Driver in Ecm was determined to be at fault. Replaced ecm, tried to program, it won't accept the programming.I was then given codes P0603, P1260, B2139, U1147 & B1845. All of which were not there prior to replacing ecm. Codes that were there prior to replacing ecm were P0351, P0352, B1202, B1323, B1318, B1410, P1137, P1157, P1408, P1131 &P1151.
Through troubleshooting it was determined that the instrument cluster needs to be replaced but I am not so sure of that since there wasn't a problem with it before. Also, doing a check of the IC it seems to be working fine, all guages doing a sweep and all lights working as well. Please help. Thank you in advance.
Avatar
Purbred
December 13, 2011.



What kind of flash program are you using. I used the borg warner and had issues doing this.

Roy

ASEMaster6371
Dec 13, 2011.
I'm using the Snap-on Pass Thru Pro II. Also used the ford Programmer with the same results.

Tiny
Purbred
Dec 13, 2011.
Then the actual pcm may be at fault. Call ford and get another one, assuming you are using a new one?

Roy

ASEMaster6371
Dec 13, 2011.
I'll try thatr

Tiny
Purbred
Dec 13, 2011.
BTW: The original ECM also now has the same codes and it is doing the same thing.

Tiny
Purbred
Dec 13, 2011.
How did you determine the pcm was bad?

Roy

ASEMaster6371
Dec 13, 2011.
#1 & #6 cylinders were missing. When I went through the diagnostic step I found that the driver in the ecm was not working.

Tiny
Purbred
Dec 13, 2011.