Mechanics

ENGINE CRANKS BUT WONT START

1998 Kia Sportage • 4 cylinder 4WD Manual • 99,000 miles

1998 Kia Sportage 4 cyl Four Wheel Drive Manual 99000 miles. While I was driving home on the I-15 in san diego(1998 Sportage is fine all day, driving it all over) and it felt like it popped out of gear (65-70mph at time), I checked to see if was in fifth and was. I stepped on the gas and it felt like the cable broke. No increases in rpms. I coasted to the side of the road ( and still on) came to a stop and I turned off the engine. The engine will crank and turn but no fire stutter or anything. I had it towed home and went to KGIS first and looked up turns over but will not start. The engine fails to start, starter turning Fuse failure Check/Replace IGN fuse - good, none popped Low battery current Check charging system -good- all elec stuff works. Ignition coil(s) failure Check/Replace coil(s)- good? Replaced last 06 CMP sensor failure Check/Replace sensor - replaced today, looked good CKP sensor failure Check charging system - replaced today, looked good fuel pump is good. Sending high pressure fuel all the way up to and past the filter. All four plugs spark, all connectors look good on coils, plugs, tps, air idle, MAS( or MAP-MAP whatever you call it) replaced crank angle and cam angle sensors. But it still won't start up, it just turns and turns. Once again timing belt is good, the head gasket is good and it's getting spark at the plugs. I'm going to check the fuel injectors resistance. But I'm out of ideas and very low on cash, so taking it in is out. I have done a lot of work my self, clutch, front hubs, speakers, audio stuff, brakes (front and rear) ect.
Avatar
2CarPros-Archives
December 7, 2010.



Get a "node" light and see if it has injector pulse. Without this, it will crank forever and not start. Scanning the PCM might not hurt either if you have or know someone with a hand held scanner.

Tiny
2CarPros-Archives
Dec 7, 2010.
Ok check this crazy **** out I have a 2000 sportage that wouldnt start I tried everything and still it wouldnt start I found out on one of these blogs where the cpu for the car is its located on the passenger side under the glove box on the floor after two weeks of messing with this car I got in jumped my dead battery and lightly tapped the cpu with a pair of pliers and what do ya know the p. O. S. Started right up my check engine light has been on when I got the car and it went off everything seems to be fine with it so far. Long live the fonz who taught me a little tap an something can make it work im telling ya all this really worked

Tiny
Dameon1031
Dec 28, 2010.