Mechanics

ACURA CL CRUISE CONTROL PROBLEM

1998 Acura CL • 198,000 miles

My cruise control stop working: I have replace all major components in this system such as Actuator assy, check valve, Controller, auto cruise switch, switch assy on steering wheel, stop & cruise switch(brake pedal), switch assy & switch assy limiter (clutch pedal). Have had it at the dealership for 2 days and still no working cruise control. Do I have to start replacing individual relays(fuse is good)? Cruise main switch light up and indicator on dash flashes four times when ignition is turned on.
Avatar
Cwcalhounsr
December 6, 2012.



So what did the dealer say was wrong with it?Any codes in the computer?

Saturntech9
Dec 6, 2012.
The tech knew what parts had been replaced as explained by the parts manager and only said that it could possible be in the wiring, but after keeping the car for a day only said he could not find the problem. I hook a code meter to the car but it is not giving a code error and I am not sure whether the four flashing of the cruise indicator when you turn it on is an error code? So far the dealership has been negative or at a lost (at least that tech). My attempt to get a more experience tech has failed(too busy).

Tiny
Cwcalhounsr
Dec 6, 2012.
You really need a scan tool that can read all the cruise inputs to see that working. In the repair info have there is no mention of theflashing light or even a trouble tree for the cruise control being inop. They just lists all the tests for the components of the cruise control. Sounds like the tech that looked at your car didnt look too hard or didn't know much about repairing your cruise control. The first thing I would have done was make sure all the inputs were working correctly on the scan tool. Like on off set accel resume cancel make sure none. Of those buttons or inputs were staying on where they shouldnt. Also that the clutch switch and brake switch were reading the correct state when pressed and released.I have seen them keep the cruise from ever coming on because it thought the brake or clutch was being applied. Also that the cruise control module cable was adjusted correctly.

Saturntech9
Dec 6, 2012.
The main switch should not light up when ignition is turned on. If it is, it means the switch has a fault or yuo have a short to power for the Light Green wire at switch. When ever the ignition switch is turned off, the switch would turn off and has to be manually turned on.

Unplug the switch and turn ignition on. Check if the dash indicator is flashing.

KHLow2008
Dec 7, 2012.
Thanks for the assit khlow2008.

Saturntech9
Dec 8, 2012.
You're welcome.

KHLow2008
Dec 8, 2012.