Mechanics

REAR WINDOW DEFROSTER DOES NOT WORK.

1997 Saturn SC1 • 10,000 miles

Trying to figure out what wires should be hot and at what time. Book I have doesnt show much for wiring on it. Had four wires hot with a test light then I have two and one real dim. Fuse is good. Tried different relay and switch. The little light dont come on. Turning on the headlight the other light will come on n I know which wire that is. It is the only swith on that plug. Thanks
Avatar
Lalfan
January 9, 2012.




You have a damaged grid. They sell a repair kit. But its only for small repairs. Replacing the glass is your only option

Cadieman
Jan 9, 2012.
So with the key in the run position and you press the defroster button it doesnt light up?Have you tried unplugging the chime module and plugging it back in?

Saturntech9
Jan 9, 2012.
No but I pulled the fuse n the radio went out. The chime dont work with doors open n key in it or on

Tiny
Lalfan
Jan 9, 2012.
So unplug the chime module and plug it back in and see if everything works make sure the module is fully seated. Let me know if that fixes it.

Saturntech9
Jan 9, 2012.
So is it the orange box on the back side of the fuse box

Tiny
Lalfan
Jan 9, 2012.
Yes and theres a tab on the bottom of it holding it in push down on the tab and pull the module out. Make sure there is no corrossion on the modules tabs. Let me know what happens.

Saturntech9
Jan 9, 2012.
Some youngerkids had it n changed stereo in it n messed with things in this area. Wasnt sure what wires where hot at what time n where they all went to. Book doesnt show much. I will try after work tomorrow. Thanks

Tiny
Lalfan
Jan 9, 2012.
Alright try that and see if it works let me know and we will go from there.

Saturntech9
Jan 9, 2012.
Pulling chime did nothing. The wiring in the plug for switck left to right is yellow pink light blue then to the right side is black white brown green brown. Key off pink has power. Key on pink is dim, white is dim, brown has full power. The brown to the far right is on with headlights. Pushing on the switch n checking it doesnt change anything.
AD

Tiny
Lalfan
Jan 9, 2012.
Check all these wires with the switch unplugged. Brown should have power with the key in the run position. The black wire should have 2 ohms or less to ground. With the switch plugged in and the key in the run position turning the switch on the light blue wire should have 2 ohms or less to ground.

Saturntech9
Jan 10, 2012.

AD