Mechanics

FAILED SMOG BECAUSE CEL

1997 Mercedes Benz C230

I have a problem with the car passing smog due to the CEL.

P0341 - OBD-II Trouble Code: P0341 Camshaft Position Sensor Circuit Range/Performance
Camshaft Position Sensor A Circuit Range/Performance (Bank 1 or single sensor)

P0141 OBD-II Trouble Code: O2 Sensor Heater Circuit Malfunction (Bank 1, Sensor 2)

I have replaced the "Camshaft Position Sensor" Already and the "O2 Sensor Bank 1, Sensor 2" which is After The Cat.

But before changing out the old O2 Sensor I used to have a different code saying

P0136 - OBD-II Trouble Code: P0136 Oxygen O2 Sensor Circuit Low Voltage (Bank1, Sensor2)
Oxygen Sensor Circuit Fault, Post Catalyst or
Oxygen O2 Sensor Circuit Low Voltage (Bank 1, Sensor 2)

Now instead I get

P0141 OBD-II Trouble Code: O2 Sensor Heater Circuit Malfunction (Bank 1, Sensor 2)

Any idea's for me? Thank You For Your Help!

P.S - Smog Test Results - http://tinyurl.com/C230TestResultKIM

Avatar
DragonBPV2
June 29, 2012.



Recheck the O2 sensor wiring. Did you use OEM or after market replacement parts?

KHLow2008
Jun 29, 2012.
These is the sensors I bought.

Camshaft Position Sensor - Around $60 (Was Installed)
Brand: Standard Motor Part
Part #: 0041530028

Oxygen Sensor - DOWNSTREAM - Around - $40 (Was Installed)
Brand: Don't Know.
Part #: 9598229

I also bought other stuff

Crankshaft Position Sensor - Around $30 (Have not Installed.)
Brand: IMC
Part #: 80233089500

Camshaft Timing Adjuster - Around $60 (Have not Installed.)
Brand: Trucktec
Manufacturer Part Number: 1190510077 or 06933047734

Ignition Wire Set - Around $50 (This was installed.)
Brand: Power Pro
Manufacturer Part Number: 2021500119

Ignition Coil - Around $40 for 2 Coils (This was not installed.)
Brand: Radiator Classic
Manufacturer Part Number: 7639

Fuel Tank Cap - $15 (Not Installed.)
Brand: STANT
Manufacturer Part Number: 10843

Pressure Regulator - $40 (Not installed)
Brand: Bosch
Manufacturer Part Number: 0280160587

Sorry about the list just wanted to put down what I was currently doing so far.

Tiny
DragonBPV2
Jun 30, 2012.
After replacement of part and you are getting trouble codes for the O2 sensor so that is where you should be looking at.

Non OEM sensors sometimes don't work correctly. The problem could also be due to the wiring circuit and have you done as suggested?

KHLow2008
Jun 30, 2012.