Mechanics

97 FAILED SMOG TEST?

1997 Mercedes Benz C230

Hi I have a 1997 C230 Benz.

I have failed the CA smog test and wanted to see if anyone can help me out.

Below is a picture of the Report.

http://tinyurl.com/MyTestSmogResult932132

Anyway please help me! thank you for your time.
AD
Avatar
DragonBPV2
May 7, 2012.




Your idling issue could be a bad or slow o2, vacuum leak or mass air flow.

You need a good shop to check it for you to confirm.

Roy

So I ordered a MAF (Part #0000940948) trying to find get the 02 for the best price but trying to find upstream and downstream right?

Could there be anything else that would be the problem with it passing the smog?

Thank You For Your Help!
AD

Tiny
DragonBPV2
May 8, 2012.
I did not say to replace them as it could be something else too. You need someone to diag it correctly and then they can tell you what needs to be replaced.

Roy

I figured out a few things about the car, like the battery that was in the car was not holding a charge because I switched the battery with a Duralast Gold and now it stays charged without any starting problems. Aside from that I have 2 CEL codes now.

1. P0341 (Camshaft Position Sensor Circuit Range/Performance)
2. P0136 (Oxygen O2 Sensor Circuit Low Voltage (Bank 1, Sensor 2))

The 2nd code just showed up until after I came back from driving the car around for a bit.

Tiny
DragonBPV2
May 10, 2012.
The 341 code be a bad sensor but needs to be confirmed with a scan tool. It could be wiring or a timing issue as well.

The 136 could be a vacuum leak as well as a lazy sensor. This can be confirmed with a scan tool monitoring the long term trims

Roy

ASEMaster6371
May 13, 2012.

AD