Mechanics

FORD EXPLORER BODY PROBLEM

1997 Ford Explorer • 98,000 miles

I have a 2001 ford ranger edge v6 sohc 4x4 160k all stock I got the truckusedabout two months ago truck ran smooth no hesitationtickingor knocking full power not sluggish at all everything worked two weeks after getting it I had the oil changed and about two days later it started running rough I changed the plugs and wires it ran better but not as good as it was so I changed the fuel filter still running at this point still not as good as it was then it got worse started dying lack of power had to keep starting it got it home and it died has not started since. I have cleaned with the proper sprays MAF idle control valve throttle body new pcv valve check the fuel cut off switch working now its not getting fuel pulled the filter nothing coming out when key is in the run position and there was when it died in the drive way first thing I checked now nothing. Check the relay. Switched with a/c relay still nothing can hear pump in tank kicking on with key turned. Still no gas from filter. Now it gets stranger truck won't start even with starting fluid just coughs a little bit when turning over then nothing and I have spark at the plugs. At the end of my rope I don't know what to do from here please help. I have been laid off but will be back to work soon and its my only vehicle please if anyone can help it would be greatly appreciated thank you in advance
Avatar
Childsart
January 9, 2013.



I would start with a fuel pump. That may be the whole issue

Roy