Mechanics

ENGINE TURNS BUT WILL NOT START

1997 Ford Expedition • V8 2WD Automatic • 265,000 miles

Ford Expedition XLT 5.4 triton 4x2 with air suspension has no fuel pressure replaced fuel pump/ sending unit, fuel filter, relay and fuse and still no pressure can u help me?
Avatar
Hotanka_86
March 20, 2011.




Do you hear the fuel pump come on, when you turn the key on? Let me know

Tiny
Rasmataz
Mar 20, 2011.
Yes the fuel pump and the sending unit come on when the key is turned on

Tiny
Hotanka_86
Mar 20, 2011.
No fuel pressure -maybe the fuel pump is coming On but not producing pressure

Tiny
Rasmataz
Mar 20, 2011.
We have just finish testing the system and there is power to the fuse and relay and both are functioning properly but there is no power in the wires to the fuel pump. Would you happen to know the routing of the wires after the distribution box?

Tiny
Hotanka_86
Mar 21, 2011.
Check and test the fuel inertia cut off switch

Tiny
Rasmataz
Mar 21, 2011.
The inertia switch registers on the dash panel when the button is pushed up and the light shuts off when button is pushed back down.

Tiny
Hotanka_86
Mar 21, 2011.
Check for power going thru it or jumper the connector and see what happens

Tiny
Rasmataz
Mar 21, 2011.
Found the problelm and fixed it. Was a corroded power wire in the connector that runs to the main harness got a new connector perfect fuel pressure started right up. Thanks fo all your help
AD

Tiny
Hotanka_86
Mar 24, 2011.
You're very welcomed and thanks for using 2carpros

Tiny
Rasmataz
Jun 29, 2011.

AD