Mechanics

WHY DOES MY CAR START BUT RPMS IMMEDIATELY DROP AND STALL MY ENGINE?

1996 Mazda Protege • 123 miles

My 96 Mazda protege LX 1.5 L seems to have never ending problems. I've asked a question before when I couldnt find my coolant leak. Had a head gasket kit and radiator installed in Oct. I provided the parts. When I got the car back, the idle seemed erratic and jumpy and close to stalling sometimes. Started leaking oil. Eventually one day while I was driving home the check engine light popped on. Took my car to a mechanic friend of the family to investigate the oil leak and also noticed that the clip to my coolant temp sensor was broken, and unplugging it from the sensor forced the fan on. (Why I dont understand). So we discovered the valve cover gasket was leaking. The shop that repaired my head gasket claims it was a faulty part and wanted more money to repair it. So the mechanic friend of the family agreed to fix it for me for cheap. Well he opened up my engine, replaced the valve cover gasket and sealed it back up. Also popped in the coolant temp sensor. Then when he went to start it, it wanted to die without gas. Managed to get it on the lift, turned it off and replaced the o2 sensors.
So I drive the car home and remain parked for probably 12 hours. When I go to start the car it revs up to about 2k before the rpms pretty much immediately drop and it dies. I can force it to run by manually holding the clutch, but must do so for a few mins before it will idle on its own. Once it is idling on its own it still seems erratic and unstable. The rpms flucate in park. Seem jumpy in gear. When I drive I have no power while trying to accelerate, and randomly while going about 30-40 I feel like I randomly feel some power kick in. I'm so tired of pumping money into this car and getting no solutions. Help please : (
Avatar
Urdeepestreality
January 25, 2012.



Check for vacuum leaks. Check and clean the egr and iac valves.

Rivermikerat
Jan 25, 2012.
Do you know where the EGR and IAC valves are on the 96 protege 1.5L engine? I got my CEL codes checked today and they are P0100, PO134, and P1170.

Tiny
Urdeepestreality
Jan 25, 2012.
I ya Mazda is known for egr problems I have a 03 p5 and had the same problem the dealer sales the upgraded for Mazda.

Tiny
Juniorsaumure
Mar 4, 2012.