Mechanics

MAZDA 626 DISTRIBUTOR PROBLEM

1995 Mazda 626 • 194,000 miles

Car seems to run fine only when slightly pressing the accelerator peddle (10% throttle or so). However when pressing it down further, starts losing spark in all cylinders and sputters. Shop thinks it's a distributor problem, already ruled out ECU (replaced, same problem).

Distributor or possibly a throttle position sensor of some kind?
Avatar
Jeremycarlson
December 10, 2012.



Scan for codes and check fuel pressure first. Clean grounds on left front and side of engine as well. It migh tnot be making good contact. Easier to do before distributor replacement.

Hmac300
Dec 10, 2012.
No check engine light is being thrown, would it still throw a code in that case?

Tiny
Jeremycarlson
Dec 10, 2012.
Fuelpressure wont' throw a code and will cause engine to run lean feelling like your condition fuel pressure should be 30-37 psi at idle w/vacuum an d 38-46 w/o vacuum

Hmac300
Dec 10, 2012.
Ok. Also when I press the throttle slightly it will rev all the way up to redline (while in neutral) if I let it. Only there is a very specific point that I reach on the throttle when the ignition cuts out.

I should restate, with a timing light connected it is clear that the ignition is cutting out with the throttle pressed further down. I don't believe it's a fuel issue.

Tiny
Jeremycarlson
Dec 10, 2012.
Then check the distributor or replace it and see if it changes. It may be a bad cam sensor init or reluctor.

Hmac300
Dec 11, 2012.