Mechanics

WHAT WOULD CAUSE AC TO WORK BEFORE REPLACING HIGH & LOW AC LINES BUT NOT AFTER??

1995 Honda Accord

I APOLOGIZE AHEAD OF TIME FOR THE LENGTH & COMPLICATED EXPLANATION.
I was recently given a '95 Honda Accord. It had an AC leak about 5 inches down from charging ports, 1 on both high & low lines. Here is how I found the leaks. The car was empty of refrigerant when given to me, so I went & bought 2 cans of refrigerant & added them. The AC was HEAVENLY for about 2 days. 3rd day, back to warm. Used gauge, it read low on refrigerant so I knew there was a leak but couldn't afford to get it fixed so bought 2 more cans since it was hot out. It again lasted about 3 days with AC ice cold. I finally came into some money so I took it to a shop. They replaced both high and low lines. The mechanic had a '95 Honda for parts & used AC lines out of that one. Total $320. On the drive home I noticed that it was ice cold when I 1st started the car, but as I got on down the road it blew warm. It was a 15 min drive home. 80% of the time it was blowing warm & did so for about 2 min then switch to cold for about 5 seconds. It did this all the way home. Next day, same thing. I'd even turn off the AC & keep vent running for a sec when it would get warm just to make sure I was hearing the compressor cut off even after it was already warm. The compressor was running the entire time, even when air was blowing warm. Took it back to the shop today & they say it now looks like the expansion valve may be blocked but they think the compressor may still be good enough to keep. They say it will cost $250 parts & labor. My question is this, if I took my car INTO the shop with the compressor ALWAYS ON & always STEADILY blowing cold air up until it leaked out of the holes, (days at a time), then wouldn't it have been something THEY did to cause it to all of the sudden not blow consistent cold AC? I don't understand what could have happened? When he hooked up the gauges to the AC lines the static pressure read high on high side (I believe around 400) and the low was 40 if not mistaken. He showed me the fluorescent green that was all around the compressor too. He didn't explain very thoroughly what the problem was though. They now want to charge me more to fix a problem that I didn't even have when I brought it in. ANY HELP or advice would be GREATLY appreciated. Trying to get some answers pretty quickly since I need to call the shop back tomorrow. Thanks : -)
Avatar
Loretta
August 26, 2011.



Generally when a compressor the expansion vale and the drier/filter. This is done to eliminate metal in the system.
It sounds like you need a new compressor and compressing refrigerant to much will turn it into a heater. Same thign will happen if you put in too much refrigerant.
Did you get oil put into the system when expansion vale changed?
The A/C pressure sensor could be bad. Since you getting some A/C for 3 days, there is a spow leak somewhere. I think you mentioned glow fluid in your question. That is an indicator of a leak.
Does the condenser fan work, (by the radiator)?
LET ME KNOW AND I WILL WATCH FOR YOur REPLY.