Mechanics

WHAT CAN I DO ABOUT MY ' ACCELERATION PROBLEM.

1995 Ford Taurus • 91,000 miles

Before the engines Temp reaches normal, the Car drives Wonderful (3.8l v6) accelerates as it is supposed to, but once it warms up, no matter how hard I accelerate it accels as if im only pressing the gas a a tiny bit, I have replaced the Throttle position sensor, (it was driving fine after replaceing it even after warmup, until the next day, it was back to problematic) fuel pump, plugs, wires, distributer cap and rotor, neutral safety switch. This issue is also causeing my MPG to suffer drastically, getting about 9 mpg, But only when the car is warm. I took it to a couple repair shops, but after telling them the issue, they turned down the buisness, seems no one even wants to LOOK at it.
Avatar
Rick44129
August 4, 2012.




Has anyone performed a back pressure test on the exhaust when it was hot?

Saturntech9
Aug 4, 2012.
No. But that sounds like a very good idea. I will try get it tested asap.

Tiny
Rick44129
Aug 4, 2012.
I think so let me know what you find.
AD

Saturntech9
Aug 4, 2012.
It has been a very long time, I finally got the money for the cats, and o2 sensors, my cats were mostly clogged, but, the acceleration problem is still there, even tho the car feels alot better, and the gas milage raised a bit, but it still is not good. A recent update is , I acceled full throttle so show someone how it accels so bad, and it jumped like as if I was letting go of the throttle or somethingthen violently smashign the throttle, (which sounds like TPS but I changed that already)
i DID need cats, so im glad I changed them, but this issue is eating me alive. Im mainly worried about my new cats, wondering if this issue is the reason my cats got clogged up. Telling the computer to dump too much fuel in cylinder

Tiny
Rick44129
Apr 10, 2013.
Has anyone done a Injector balance test?Or tested the coolant temp sensor?

Saturntech9
Apr 10, 2013.

AD