Mechanics

SPEEDOMETER

1995 Ford F-150 • 5.0L V8 4WD Automatic • 157,000 miles

The speedometer in my 1995 ford f-150 is not working properly. It will work fine until it reaches 35-40 mph, but then starts jumping around. The odometer seems to be working correctly. I have replaced the diff. Sensor, trans. Sensor and speedometer head with no luck. The truck has been sitting idle for about a year. Any help would be appreciated.
Avatar
Bbowen
August 3, 2014.




This could be a wiring issue or the item in the pic which is an amplifier for the speed sensor not sure if a scanner will pick that up or not. See pic


Hmac300
Aug 3, 2014.
Checked wiring and all seems okay, any way to check amp? Could a bad ground to dashboard cause this. Thanks.
AD


Tiny
Bbowen
Aug 3, 2014.
I guess the ground could as well as abad or poor connection maybe at cluster. Never really thought about it. But if the amplifier wasn't working or had a bad ground it might do it as it would get a ground then send the signal then not. It almost 20 yrs old so it cold be a bad ground from battery considering the age of it. Or one that is supposed to be there and isn't or it can even be dirty battery terminal ends. That is about all I can think of. Check the fusible links in pic they shold have power on both sides same a s battery and wiggle them around to test as it may have just a few strands attached and not making good contact that may do it as well. Kinda hard to figure out without seeing it.


Hmac300
Aug 3, 2014.

AD