Mechanics

95 F150 5.8L - WHY DOESNT STARTING FLUID IGNITE WHEN SPRAYED INTO MY FUEL INJECTOR?

1995 Ford F-150 • 162,000 miles

I just bought a 95 f-150 5.8L I don't know if there was foul play but for some reason the truck stopped running! It turns over but doesn't ignite ether in the injector!
Avatar
IA-95_f-150
January 25, 2012.




Is there spark?
AD

Tiny
Fixitmr
Jan 25, 2012.
From the distributor yes, new battery also! I think it could be the wires may have been switched, or maybe the ignition module! What are some symptoms of each? I just bought the special tool to take out the ignition module but havent started that yet! What order do the plugs go from the distributor to the plugs?

Tiny
IA-95_f-150
Jan 25, 2012.
If they were out of order it should backfire. You say it dont fire at all? Are plugs wet?

Tiny
Fixitmr
Jan 25, 2012.
No, the plugs are not wet and I just tested the ignition modular and it is working!

Tiny
IA-95_f-150
Jan 25, 2012.
Is it real cold there? No sputters at all? Try dumping some gas down it's throat. Spray start evaps so quick.

Tiny
Fixitmr
Jan 25, 2012.
A few days ago, yes it was kinda cold! I will try the gas down the throat and let you know if that works in the morning! I appreciate the help!

Tiny
IA-95_f-150
Jan 26, 2012.
You can check for spark at the plugs, just get a spare plug and earth it to the engine and plug any lead into it, crank and watch for a spark, you will want to see a strong blue spark that cracks when it fires.

Mhpautos
Jan 26, 2012.

AD