Mechanics

ROUGH IDLE

1995 Ford Escort • 4 cylinder FWD Manual • 125,000 miles

I have a 1995 Ford Escort wagon 1.9. I changed my IAC, changed pcv valve & put new spark plug wires on & cleaned my battery cables and it still idles rough. The idle drops to 500 rpm's then goes back to 750 rpm's when I come to a complete stop everytime.
Avatar
Ringo66
May 22, 2011.




Hello,

Ok, you replace the plug wires, what about the Plugs themselves?

Obxautomedic
May 22, 2011.
Oh, also check for vacuum leaks.

Obxautomedic
May 22, 2011.
I took the plugs out & they we're in great shape. I looked for vacuum leaks also.

Tiny
Ringo66
May 22, 2011.
Ok, is engine light on? If so get codes read and post them.
Also, FYI, Just because a plug looks in good shape doesn't mean it is working properly. I have seen plugs that have cracked were the ceramic meets the metal and the spark is jumping to ground causing a misfire and a rough running engine.

Another possibility is the MAF (Mass Air Flow) Sensor.

Obxautomedic
May 22, 2011.
Could it be the EGR valve?

Tiny
Ringo66
May 22, 2011.
Yes, it could be the EGR. I start with the simplest possibilities first with a rough or misfiring engine condition.

I mensioned the MAF cause it can easily be cleaned with some MAF Cleaner. You can also disconnect it, the computer will go into a default mode and your vehicle will run normally.

And since you brought in the EGR, it could also be the EGR Control Solenoid or the EGR Pressure feedback Sensor.

Other possibilities are.

Exhaust Leak

Faulty Injector

Weak Fuel Pump

Blown Head Gasket

Is the engine light on? If so get codes pulled will help narrow the field.
AD

Obxautomedic
May 22, 2011.

AD