Mechanics

P073 INTERNITTENT COOLANT TEMP. SENSOR

1995 Cadillac Concours • 182 miles

I have a 95 cadillac concours with a northstar v8 4.6. It keeps telling me in the on board diagnostics that it keeps getting a p073 intermitent temp sensor code. It bogs down the motor for a second but straightens back out in a split second. I have replaced the E.C.T. Sensor and it still throws the code after reseting the pcm code from the on board diagnostic center. Every once in awhile it will say "engine overheated turn off engine" just for a split second almost not enough time to read the message! I have recently replace the radiator, water pump, thermostat, antifreeze, trans fluid, gasket and filters, plugs and wires, A.C.M, checked all fuses, and checked the wiring(the best I can without completely unplugging and tearing them out). This p073 is getting under my skin cause it bogs my car down just for a second and I cant figure it out any suggestions from anyone would be greatly appreciated.


Avatar
Trudrew
April 22, 2012.



-Check the ECT sensor wiring back to the computer

Rasmataz
Apr 22, 2012.
Have you checked wiring to the ECT? Check for damage and corrosion.

I have checked that and even took a qtip and electronic cleaner to it. No wires look broke and the contacts look good. As I stated in my original message I have traced the all the wires. I looked from the sensor to the firewall and then under the dash to the p.C.M.

Tiny
Trudrew
Apr 22, 2012.
Have you tried unplugging the ECT sensor does it do the same thing

Rasmataz
Apr 22, 2012.
It comes up another code I dont remember wich one but it says open sensor I think

Tiny
Trudrew
Apr 22, 2012.
So I take it noone has any suggestions?

Tiny
Trudrew
Apr 24, 2012.
It comes up another code I dont remember wich one but it says open sensor I think: Lets have it so that we can continue if not we need to know what is this open sensor-

Rasmataz
Apr 24, 2012.