Mechanics

WAGON 2.2 NON TURBO ,4CYL

1993 Subaru Legacy • 4 cylinder FWD Automatic • 151,976 miles

The problem im having is the car wont start. Checked fuel got fuel at spark plugs pulled out spark plugs , checked for spark at the coil have spark at the front 2 spark plug wires the back 2 or dead. Changed out the coil with a new hitachi ingition coil same problem checked resistance its right on acording to the book so I changed out the wires plugs, same thing no spark on back also switched wires from front to back with the spark plug out of engine on ground. So next I checked the feed going to the coil I have power on one wire nothing on wire going to the back then I changed out the ignitor same problem so used a test light with ignitor pluged in I used I have power on one wire when key is on on the left side the light comes on when the car is started right side is dead next I unpluged the ingitor hooked the clip of the test light to the pos. Side of battery thin I put the test light to the wires of the ingitor the light came on on all wires also I changed out the camshaft position sensor, crankshaft position sensor then I unpluged one at a time and checked for spark on the front lost spark so I pluged it back in did that for both also looked for the e.C.M. Acording to the book its should b at passenger compartment right side under carpet its not there im out of ideas please help the vin number is 4s3bj6335p9950245
Avatar
Eagle96us
January 9, 2011.




Check out the related content below while we wait for the question to be answered by a professional mechanic.


AD