Mechanics

WHAT IS CAUSING MY CAR TO NOT HAVE POWER AND ALSO SHAKE AND VIBRATE?

1993 Oldsmobile Cutlass • 138,000 miles

Over the last month my car cranks fine. As soon as I pull off though, it acts as if it is going to cut off and acts as it is not going to make it up a slight hill. Just no power, it kind of jumps a long. And also, it has started shaking bad, especially going up hill. Now its doing it even when Im on the interstate. If I let off of the gas. It stops shaking and just coasts. But when I mash the gas, it shakes bad and also loses power as I mash the gas. I have an automatic transmission. And again, it cranks and sounds fine. Just when I put it in drive and start moving does this happen. Please help? I dont have a lot of money to spend on a mechanic and and this is only car I have to get to and from work. MUCH THANKS !
Avatar
Da082567
December 16, 2011.



Check the EGR. Check the idle air control valve. Check the catalytic converter by removing it temporarily and bypassing it. Have the computer scanned for both soft and hard codes.

Rivermikerat
Dec 16, 2011.
I have a 1997 Cutlass supreme and it has almost the same symptoms as your vehicle. I have had every sensor changed. Spark plugs, wires, fuel filter, fuel pump. I took it to multiple transmission shops. I had 3 mechanics tell me it was the transmission. My car has 190,000 miles I had the engine replaced almost 2 years ago with a engine that has 90,000 miles. I just had the transmission replaced a couple weeks ago and obviously that was not the issue. Because my car is still doing the same symptoms. I took it back to the transmission shop and the mechanic said its def a engine issue. I have had everything checked. No codes show up and I have had multiple diagnostics done.

Tiny
Detzlera
Jan 11, 2012.
I noticed my car also is getting worse as I drive it. It has a lack of power and I have to slam on the gas just to get it up to speed. Now when I get to about 50-55 mph the engine starts to shack really bad. When I let off the gas it will stop. The rpm's will go super high and I will only be going about 20mph. Let me know if you find out any solutions with your vehicle. I am leaning towards a engine issue. Lack of fuel in the engine, or maybe some sort of air leak. IDK anymore, would like to ram it into a tree!

Tiny
Detzlera
Jan 11, 2012.
Check compression and fuel pressure. Check the catalytic converter by temporarily removing it and taking it for a test drive.

Rivermikerat
Jan 11, 2012.