Mechanics

I HAVE A WITH 4WD WITH A TRANNY PROBLEM

1993 Mazda MPV • 125,000 miles

My 1993 Mazda MPV's transmission. I replaced the transmission with one that I had taken out of my old MPV as it worked fine. I bout this MPV with a bad tranny. I changed the tranny and it worked fine for about 3mnths with no problems. One day I took it out to drop off a friend and after about 6 or 7 miles I turned onto a road and the vehicle down shifted like normal then all of a sudden it stopped moving at all. There were no noises or slipping and grabbing, it just would not move since then. Is it possible that it is electrical or can a plugged cooler line do that as I did not replace the cooler. It just seems very strange that it had no previous symptoms and it happened all of a sudden. I tried in vain to change the fluid and filter but it did no good. As a matter of fact if you put it in gear the rpms actually rise a little rather than going down. I need help, thank you in advance. I really enjoy the vehicle and would like to have it running. Tab
Avatar
Tabbycat
December 8, 2011.



Either a torque converter failure or a pump failure. Either way, it has to come out and most likely be rebuilt.

Roy

Sounds like torque converter failure to me. Did you flush the lines and cooler before you put in the donor tranny?Did you re-use the same torque converter?If you didn't flush or used same converter there could have been particles in there that damaged the pump or converter.

Homer1967
Dec 8, 2011.