Mechanics

BAD/LOW POWER UP-HILL

1993 Ford Ranger • 99,999 miles

So after removing sparks plugs, I was told STEAM came out of #4 SPARK plug hole. What should be my next check/step?
Avatar
Nevadavic
May 26, 2012.



Are you loosing coolant? How was it determined to be steam and say not gas vapors form leaky injector?


Tiny
Fixitmr
May 26, 2012.
Did spark plug look different from other cylinders? Like really clean or funny deposits?


Tiny
Fixitmr
May 26, 2012.
Good questions. I will have to check. Thanks!


Tiny
Nevadavic
May 27, 2012.
Nevadavic: What's the verdict on this? Was it steam or gas vapor? Is that plug cleaner than the rest?


Rivermikerat
Jul 29, 2012.
All good Q's! But I already researched as U all suggested. No loss of coolant, and no the plug was similar color as others. Turns out it was not steam was just hot gases. The problem was/is the transmission. The uphill issue matured into an acceleration issue but the tachometer did not fluctuate during acceleration! Long story but the Xmission needs to be worked on. Thanx for support!


Tiny
Nevadavic
Aug 1, 2012.
Our pleasure. Thanks for the update. By the way, do you know the history of "Kilroy was here" ?


Rivermikerat
Aug 2, 2012.
The history of "Kilroy was here"?
Yes, a friend sent me the history in E-mail. Do you want?


Tiny
Nevadavic
Aug 2, 2012.
No. I know it. Kilroy was a rivet inspector at the Bath Shipyard during WWII. But thanks. I've actually met some of his relatives when went to school out there.


Rivermikerat
Aug 2, 2012.