Mechanics

FUEL PUMP NOT GETTING POWER

1993 Dodge Dynasty • 200 miles

Relay is good, all wiring looks good. It smelt like an elextrical fire when I tried to start it, had small amount of smoke in the intake, then it wouldnt fire back up, I have replaced the fuel pump, and have compression in all cylinders, just no fuel, it fires just fine with starter fluid
Avatar
Tanman
September 6, 2011.




200000 miles*

Tiny
Tanman
Sep 6, 2011.
The fuel pump should only run for one second after you turn on the ignition switch. It won't turn on again until the engine is rotating, (cranking or running).

The few common failure items are working since it has spark. That leaves the fuel pump circuit. What have you tested so far?

Caradiodoc
Sep 6, 2011.
I just found the issue. It's the computer on the driver side. It has a short.

Tiny
Tanman
Sep 6, 2011.
That is extremely uncommon. How did you arrive at that? What else isn't working if anything?

Caradiodoc
Sep 6, 2011.
I saw a small amount of white smoke coming from the intake, proceded to remove it, smelt electrical fire, removed computer cover and used a jumper wire to activate the fuel pump relay, saw the short,
the things leading to this issue were gauge malfunctions, radio/clock not working, and a parasitic drain on the battery.

Tiny
Tanman
Sep 6, 2011.
What was shorted? Were two wires touching or was one grounded?
AD

Caradiodoc
Sep 6, 2011.
Inside of the computer. I'm not sure what it was. It's sealed with jelly stuffs

Tiny
Tanman
Sep 6, 2011.

AD