Mechanics

BUICK LESABRE SENSOR PROBLEM

1992 Buick Lesabre • 233,000 miles

New question, or part of old question: I have dtc 41, and 58. When at dead stop, and almost at dead stop, when I hit the gas, engine rpms go up, but does not go anywhere, then after a few secs, it goes. Just changed o2 sensor, and transmission fluid. I had a code 13, but cleared it with new o2 sensor. The car used to stall, but it seems with better gas choice(Chevron, Shell, Exxon) it has stopped. After a period, this started, and oddly after new o2 sensor, and new transmission fluid, it seems to have gotten worst. (Not sure if this is related) Old o2 sensor, had white on it like maybe it was ash or something, not sure. Also, noticed oil around where the cylinder head & block meets, as well as a Very "Slight" clear drip from exhaust pipe sometimes. When I used to start car, it used to have an "odd" smell for a few secs, and no more after that. Since new o2 sensor, I havent noticed the smell. I don't believe it's a gas smell, don't think rotten eggs either. Sorry so long, but wanted to include details. Help with this would greatly be appreciated. Also, engine does idle rough at times. Can some one also help with dtc 41 and 58 please.
Posted by Gvsdaworld on 2/18/2013
. Details
New question, or part of old question: I have dtc 41, and 58. When at dead stop, and almost at dead stop, when I hit the gas, engine rpms go up, but does not go anywhere, then after a few secs, it goes. Just changed o2 sensor, and transmission fluid. I had a code 13, but cleared it with new o2 sensor. The car used to stall, but it seems with better gas choice(Chevron, Shell, Exxon) it has stopped. After a period, this started, and oddly after new o2 sensor, and new transmission fluid, it seems to have gotten worst. (Not sure if this is related) Old o2 sensor, had white on it like maybe it was ash or something, not sure. Also, noticed oil around where the cylinder head & block meets, as well as a Very "Slight" clear drip from exhaust pipe sometimes. When I used to start car, it used to have an "odd" smell for a few secs, and no more after that. Since new o2 sensor, I havent noticed the smell. I don't believe it's a gas smell, don't think rotten eggs either. Sorry so long, but wanted to include details. Help with this would greatly be appreciated. Also, engine does idle rough at times. Can some one also help with dtc 41 and 58 please.
Avatar
Gvsdaworld
February 18, 2013.



Check out the related content below while we wait for the question to be answered by a professional mechanic.