Mechanics

MY TRUCK SOMETIMES STARTS SPUTTERING, TRIES TO STALL WHILE DRIVING. THE RPMS GO UP BUT IT WILL NOT EXCELLERATE WHEN APPLYING THE GAS. NOT ALL THE TIM

1991 Mazda b2200 • 200,000 miles

There's no rhym or reason to it I can drive around for hours then all a sudden it's like the engine bogs down RPMs go up but it will not accelerate i've done tune up, oilchange, fixed vacum leak, just put fuel filter on the old one had very dark gas in it could there be some underlying problem there. Also valve cover gasket is leaking slightly from the vacumm problem I think any suggestions are appreciated
Avatar
Glencroft
August 5, 2012.



From your description, it may be a trans issue. Check the fluid. When was the last time you service it?

Roy

I just bought the truck it had been setting a few years The trans fluid looks good it shifts fine. I have noticed it seems to do it more around 25mph well today it was doing it around 45mph Would the trany act up just ever now and then like this It could be a week before it does it again, and smoothes out as quickly as it begins

Tiny
Glencroft
Aug 5, 2012.
Sure could. Get it checked to be sure by a trans shop to confirm.

Roy

Thanks I had an inkling just hoping it's not that

Tiny
Glencroft
Aug 5, 2012.
It can be the trans but it can be the engine as well. The trans downshifts resulting in the rpm going up but accelerating power is lost then.

Does the rpm shoot up very high or only goes to a certain rpm and holds while the vehicle struggles to gain speed?

Is the MIL indicating and have you checked for trouble codes?
If EGR is used, check that.

KHLow2008
Aug 5, 2012.