Mechanics

WHY IS ONE SIDE OF THE RADIO HAVE STATIC?

1991 Chevrolet Van • 103,000 miles

When I play the radio or tape it will get fuzzy on only the passenger side. Dash, door and rear speakers. It still has the stock radio in it
Avatar
Kylehertzler
December 16, 2011.



I would start by making sure the wiring harness to the rear of the radio is tight. It may have come loose over the years.

I have the radio out and the wires are in tight and it is still fuzzy. I tried wiggling them but that doesn't change anything.

Tiny
Kylehertzler
Dec 16, 2011.
The only other thing that I can think of is the amp in the radio is starting to go bad.

Ok I am getting a radio out of a 96 buick regal according to some other sites online that should fit. In case it doesn't what do you suggest? Go to a scrap yard or get a new one?

Tiny
Kylehertzler
Dec 16, 2011.
It should fit. If it doesn't, go to a salvage yard and get one. If you get an aftermarket one, then you need to modify the wiring.

Alright thanks for all your help I will see what happens.

Tiny
Kylehertzler
Dec 16, 2011.
Let me know if you have other questions.

Did you test the speaker?

Tiny
Fixitmr
Dec 16, 2011.
The way that I tested it was hard to tell but it is all the speakers on the passenger side. All the ones on the drivers side are ok. I have a headphone jack with 2 bare wires that I put into my iPod and then touched to the hot points and some sound came through. Is there a better way to test it?

Tiny
Kylehertzler
Dec 16, 2011.
Well ideally if you could rig good side to play out other side that would be the best test.

Tiny
Fixitmr
Dec 17, 2011.